Archiv für den Monat: September 2014

Server-Manager hängt bei „Installation wird gestartet…“

Windows bringt einen schon manchmal zum verzweifeln. Hier habe ich mal wieder ein Beispiel, was mich einiges an Nerven gekostet hat.

Bei der Installation einer Rolle oder eines Features unter Windows Server 2012 hatte ich das Problem, dass er immer am Punkt „Installation wird gestartet…“ hängen blieb.

Nach etwas Recherche bin ich darüber gestolpert, dass WinRM die Ursache sein könnte. Also versuchte ich es wie gewohnt über die Kommandozeile mit „winrm quickconfig“ zu aktivieren, was in folgender Fehlermeldung resultierte:

Der WinRM-Dienst wird auf diesem Computer bereits ausgeführt.
WSManFault
    Message = Der WinRM-Client hat einen Status in Bezug auf einen HTTP-Serverfehler (500) empfangen, 
aber der Remotedienst hat keine anderen Informationen zur Fehlerursache bereitgestellt.

Fehlernummer:  -2144108176 0x80338170
Der WinRM-Client hat einen Status in Bezug auf einen HTTP-Serverfehler (500) empfangen, aber der 
Remotedienst hat keine anderen Informationen zur Fehlerursache bereitgestellt.

Nach weiterer Suche ist mir dann aufgefallen, dass im Server-Manager unter Lokaler Server bei dem Punkt Remoteverwaltung nur „Unbekannt“ stand. Beim Klick darauf sah das ganze dann so aus:

Remoteverwaltung-Fehler

Die genaue Fehlermeldung lautete hier:

Interner Fehler beim Lesen des Remotingzustands: Der WinRM-Client hat einen Status in Bezug auf einen HTTP-Serverfehler (500) empfangen, 
aber der Remotedienst hat keine anderen Informationen zur Fehlerursache bereitgestellt.

Hier hat es geholfen, die Remoteverwaltung zu deaktivieren, mit OK zu bestätigen und wieder erneut zu aktivieren.

Allerdings muss ich dabei anmerken, dass das Problem einige Tage später, eventuell nach einem Neustart, wieder auftrat.